Entre para seguir isso  
Guest - Thiago Camargo -

Qual A Diferença Entre Php4 E Php5? Sou Leigo

Recommended Posts

Guest - Thiago Camargo -   
Guest - Thiago Camargo -

Olá gente desculpem minha ignorância, mais eu tenho um conhecimento em web... (HTML, JAVASCRIPT, Pouco de ASP) e nunca ví versões de linguagem... tipo html 3 ou 4, já o PHP encontrei isso... Estou apenas estudando a teoria ainda... um dia eu chego lá wink.gif

E o que mais em intrigou foi que nas hospedagens umas aceitam o PHP 4 já outras só o PHP 5... As minhas perguntas são as seguintes:

O porque destas versões?

Qual a padrão? (Se é que existe)

O que uma versão faz que a outra não faz?

Espero que possam ajudar...

valeu galera!

Obs.: Se tiverem algo mais a acrescentar... como outras definições importantes podem postar.

Fui.

Compartilhar este post


Link para o post
Compartilhar em outros sites
>>FD00J8<<    0

Cara o que usei do que estudei até agora é que o PHP5 tem uma série de funções especiais para o MySql4.x utilizando a mesma notação dos MySql's anteriores adicionando o i por exemplo!

mysqli_num_rows()

mysqli_fetch_row()

Se eu estou errado por favor me corrijam!! também sou leigo em PHP!! hehe

Compartilhar este post


Link para o post
Compartilhar em outros sites
Guest - Thiago Camargo -   
Guest - Thiago Camargo -

Putz... de leigo para leigo...hehehehe

huh.gifhuh.gifhuh.gif

Compartilhar este post


Link para o post
Compartilhar em outros sites
Fabyo    0

Cara toda linguagem tem versoes e sempre vao ser atualizadas

vb,delphi,pascal,,cliper,C,php,asp,etc...

e cada versao visa tentar melhor e corrigir bugs e incrementar algo novo

no caso do php a ultima versao dele é a 5.1 ele vem com mais funções orientado a objetos e com mais funções novas ,mas ainda esta com um problemas de bugs e por enquanto a maioria do pessoal esta usando php4 mesmo

mas isso acontece em qualquer linguagem ate o windows tem problemas e por isso que existe atualizações no windowsupdate

o linux também sempre atualizando o kernel,KDE etc...

e a melhor versao sempre vai ser a ultima desque a mesma já esteja estabilizada

e sem muitos bugs

beleza?

ate logo

Compartilhar este post


Link para o post
Compartilhar em outros sites
chackal_sjc    0

tipo

porque ter o php5 se os servidores não tem suporte para php5 ainda...

sei la... o que eu tenho para testar meus scripts é tudo em php4... e eu nunca vi em php5!

Compartilhar este post


Link para o post
Compartilhar em outros sites
Fabyo    0

Tem sim os servidores estao migrando para o php5 ate o infinitehost já esta com o php5

mas foi o que eu falei eu não to usando o php5 porque pra mim hj ele esta com algumas falhas mas assim que melhorar eu passo a usar

Compartilhar este post


Link para o post
Compartilhar em outros sites
Guest --Wesley --   
Guest --Wesley --

ai galera sem maldade uso o php5 usei ele para um site q hospedei na locaweb e la rodou normal agora eu tenho um para hospedar no locahost e to meio enrolado pois tentei importar um banco em php5 para o banco deles e deu erro tipo versão não compativel o q faço qual a diferença entre esses cripts para mim mudar para o 4

qeum poder ajudar valeu

Compartilhar este post


Link para o post
Compartilhar em outros sites
MLeandroJr!    0

Na verdade, se o seu host (Locaweb) já trabalha com o PHP 5, recomendo que você o coloque em localhost também, pois assim você:

- Se acostumará a desenvolver para PHP 5, eliminando alguns possíveis vícios criados pelo PHP até a versão 4.

- Evitará incompatibilidades de versões como essa que você está sofrendo agora, e que provavelmente não é com o PHP, mas com o MySQL.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

Entre para seguir isso