Entre para seguir isso  
Seguidores 0
Bruno Pacheco

Visualg (- comandos de decisão -"se então")

8 posts neste tópico

3) Em uma competição de saltos ornamentais, 6 (seis) juízes informam notas reais

variando de 0 a 10. A nota final do atleta deve excluir a maior e a menor nota dos juízes

e é composta pela soma das quatro demais notas. Faça um programa que lê do usuário

as seis notas dos juízes e informa a nota final do atleta (a soma das notas excluindo a

menor e a maior delas).

OBS.:"Minha dúvida é mais na parte do processamento desse algoritmo".

Editado por Bruno Pacheco

Compartilhar este post


Link para o post
Compartilhar em outros sites

Poste o código e não a imagem, para poder ficar mais facil mexer no código... basta marcar, copiar e colar no forum

Compartilhar este post


Link para o post
Compartilhar em outros sites
já colei o código da imagem

Onde ??? coloque o seu código aqui e não um caminho para uma imagem ... pela imagem não tem como fazer alterações no seu código

Compartilhar este post


Link para o post
Compartilhar em outros sites

var

notareal1,notareal2,notareal3,notareal4,notareal5,notareal6:inteiro

notafinalatleta:inteiro

inicio

escreval("digite a nota real 1:")

leia(notareal1)

escreval("digite a nota real 2:")

leia(notareal2)

escreval("digite a nota real 3:")

leia(notareal3)

escreval("digite a nota real 4:")

leia(notareal4)

escreval("digite a nota real 5:")

leia(notareal5)

escreval("digite a nota real 6 :")

leia(notareal6)

escreval("a nota real 1 é:",notareal1)

escreval("a nota real 2 é:",notareal2)

escreval("a nota real 3 é:",notareal3)

escreval("a nota real 4 é:",notareal4)

escreval("a nota real 5 é:",notareal5)

escreval("a nota real 6 é:",notareal6)

escreval("a nota final do atleta:",notafinalatleta)

Editado por Bruno Pacheco

Compartilhar este post


Link para o post
Compartilhar em outros sites
Agora eu pergunto eu tenho dúvida na parte do processamento como vou fazer para achar a maior nota e a menor nota?

var
notareal1,notareal2,notareal3,notareal4,notareal5,notareal6:inteiro
notafinalatleta:inteiro
notamaior, notamenor:inteiro

inicio
escreval("digite a nota real 1:")
leia(notareal1)
escreval("digite a nota real 2:")
leia(notareal2)
escreval("digite a nota real 3:")
leia(notareal3)
escreval("digite a nota real 4:")
leia(notareal4)
escreval("digite a nota real 5:")
leia(notareal5)
escreval("digite a nota real 6 :")
leia(notareal6)

notamaior = notareal1

se notamaior < notareal2 então
    notamaior = notareal2
fimse

se notamaior < notareal3 então
    notamaior = notareal3
fimse

se notamaior < notareal4 então
    notamaior = notareal4
fimse

se notamaior < notareal5 então
    notamaior = notareal5
fimse

se notamaior < notareal6 então
    notamaior = notareal6
fimse

notamenor = notareal1

se notamenor > notareal2 então
    notamenor = notareal2
fimse

se notamenor > notareal3 então
    notamenor = notareal3
fimse

se notamenor > notareal4 então
    notamenor = notareal4
fimse

se notamenor > notareal5 então
    notamenor = notareal5
fimse

se notamenor > notareal6 então
    notamenor = notareal6
fimse

escreval("a nota maior  é:",notamaior)
escreval("a nota menor é:",notamenor)
fim

OBS: Para achar a maior nota voce tem que comparar cada uma das notas com as outras.. quando uma delas for maior que aquela armazenada na variavel notamaior, então a variavel notamaior recebe o valor da variavel que estiver sendo comparada

para nota menor o processo é o inverso .... leia mais sobre lógica de programação

abraço

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!


Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.


Entrar Agora
Entre para seguir isso  
Seguidores 0