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INTRODUCAO

Flash é o padrao da Web para animagéo e imagens vetoriais. Com o Flash, vocé pode rapidamente dar
vida as suas péaginas da Web com imagens animadas e efeitos de texto. O Flash também permite incluir

uma interatividade sofisticada ao seu site sem programacéo de scripts complicada.

O Flash foi desenvolvido para fazer com que suas animagbes da Web sejam descarregadas e comecem
a ser executadas rapidamente. Como ele cria imagens baseadas em vetores, consegue gerar arquivos
que séo descarregados em um tempo menor do que os formatos de imagens em bitmap, como GlIFs e
JPEGs. Além disso, o formato streaming do Flash indica que os filmes da Web podem comecar a ser
executados enquanto ainda estéo sendo descarregados. Seus usuérios néo precisaréo esperar para

iniciar a interagdo com os filmes do Flash.

O ambiente de criagéo do Flash proporciona um conjunto completo de ferramentas para a construgéo de
animacdes prontas para a Web. As ferramentas de desenho e texto permitem que vocé crie imagens e
texto a partir do zero. O Flash também pode importar imagens de outros programas graficos, como o
Freehand e o lllustrator, bem como bitmaps criados em programas como o Photoshop. A linha de tempo
do Flash, que seréa familiar aqueles que ja utilizaram o Macromedia Director, permite que vocé aplique
animagdes e interagdes complexas em seus filmes, com controle quadro a quadro. Apos criar um filme
completo no Flash, vocé poderé exporta-lo para o formato de arquivo compactado .swf e usar o

Aftershock para adicionar o filme a uma pagina da Web.

Este curso conduzird vocé passo a passo pelo processo de construgdo de uma animagao interativa no
Flash. Vocé aprendera a configurar um “filme” animado, desenhar personagens, adicionar texto, animar
tanto o texto quanto os personagens, adicionar botdes interativos para controlar as animagoes e,
finalmente, exportar suas animagdes para um arquivo pronto para a Web. Nesta licdo encontra-se um
arquivo denominado final.fla, que mostra a verséo final do filme no qual vocé estaré trabalhando durante

a ligéo.

O exercicio no qual vocé trabalhara produzird um filme animado simples com botdes interativos. Mas a
utilidade do Flash vai além das animagdes estilo desenho animado ou cinema na Web. Sua capacidade
de responder & entrada de dados do usuario e iniciar paginas da Web torna-o util na construgéo dos
elementos da interface do usuério, como barras de navegacéo e menus suspensos, que podem ser

adicionados as suas paginas da Web normais.

A medida que for prosseguindo na licdo, sinta-se a vontade para verificar a documentagéo on-line do
Flash para obter mais técnicas avangadas e mais informacdes detalhadas. O site da Macromedia na

Web, www.macromedia.com, fornece ainda mais recursos em seu centro de desenvolvedores do Flash.
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LIGAO 1: FAMILIARIZANDO-SE COM O FLASH

OBJETIVOS

Nesta licdo, vocé aprendera a:

e configurar um novo arquivo de filme do Flash
e usar as ferramentas internas de desenho do Flash para criar imagens e texto
e trabalhar com a barra de ferramentas e com o Stage

CONTEXTO

O primeiro passo para produzir uma animagao do Flash pronta para a Web é criar os personagens que
serdo usados em sua animagao. Neste capitulo, vocé criara alguns personagens e texto simples usando as
ferramentas de desenho localizadas na barra de ferramentas do Flash. Vocé se surpreenderd com a
facilidade de criagéo das imagens no Flash, mesmo que nunca tenha usado um programa de desenho para
computador. Nao fique com medo de experimentar e brincar com as diferentes ferramentas e opgdes.

A animagao que vocé criara ao final mostrard uma formiga movendo-se pela tela da esquerda para a direita.
Vocé deixara o dia ensolarado. Finalmente, acrescentara algum texto explicativo e, mais tarde, o animara

também.

EXERCICIOS

CRIANDO UM NOVO FILME DO FLASH

As sequéncias de animagéo no Flash sédo chamadas de “filmes”. Porém, vocé nao precisa de uma camera
de cinema para criar um filme do Flash; vocé mesmo pode criar uma, desenhando personagens e, depois,
animando-os. Neste exercicio, vocé configurara um novo arquivo e aprenderd a alterar as dimensoes totais

do filme.

Primeiro, abra o programa Flash. O Flash abrira automaticamente um novo documento. No futuro, vocé
poderé criar novos filmes do Flash escolhendo File > New.

Examine as Propriedades do Filme
1. Escolha Modify > Movie.

O Flash exibe a caixa de didlogo Movie Properties (Figura 1-1).
2. Deixe o Frame Rate em seu padrdo de 12 fps.

“fps” significa quadros por segundo e determina o grau de suavidade que sua animagéo terd quando
for executada. 12 fps devem produzir bons resultados para a Web. (Apenas como referéncia, as
imagens dos filmes de cinema séo executadas em 24 fps no cinema, enquanto os filmes do
Quicktime s&o geralmente 12 fps.)
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3. Deixe as Dimensions em seu padrao de 550 x 400 pixels.

E um bom tamanho para se comegar. Mais tarde, talvez vocé queira tornar seu filme maior ou
menor. O tamanho menor permitido é de 18 x 18 pixels; o maior é de 2880 x 2880 pixels. Apds criar
um filme, vocé poderéa usar a opgdo Match: Contents para revelar um espago nao-utilizado.

As dimensoes de seu filme determinardo o tamanho da area do navegador da Web que o filme ira

ocupar.
4. Cliqgue em OK para continuar.

Vocé sempre poderé retornar as propriedades de seu filme posteriormente e altera-las. Mas é

importante estabelecer a freqtiéncia de quadros antes de iniciar.

Movie Properties

Frame Rate: fps -
e s

Dimensions: [550px | x [400px |

Match: [ Printer ] [Cuntents]

Grid [J Show grid
Grid Background

Colors: :I :I

Save Default

Ruler Units:

Figura 1-1

A caixa de didlogo Movie Properties determina a freqliéncia de

guadros e o tamanho do filme.

DESENHANDO UM NOVO PERSONAGEM

Inicie uma nova animacgéo pelo desenho do personagem formiga usando
as ferramentas de desenho no Flash Toolbar. Enquanto vocé trabalha
com as ferramentas, observe que a metade inferior da caixa de ferra-
mentas contém modificadores relacionados ao contexto (Figura 1-2)
que fornecem opc¢odes diferentes baseadas na ferramenta que vocé
selecionou a partir da parte superior da barra de ferramentas. No meio
da barra de ferramentas, o menu pop-up proximo ao nimero de %

permite que vocé redimensione o filme.

Vocé desenhara a formiga na grande area branca na parte inferior
esquerda do documento. Essa area é chamada Stage. Vocé pode
desenhar imagens no Stage e mais tarde executar suas animagdes
nele. Observe que o tamanho do Stage € determinado pelas
dimensdes em pixel na caixa de didlogo Movie Properties, que vocé

observou anteriormente.
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Figura 1-2

A metade superior da barra de
ferramentas contém as ferramentas
basicas, enquanto a metade inferior
fornece modificadores, dependendo da
ferramenta selecionada.
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Figura 1-3
A grande area branca na parte inferior esquerda do documento € o Stage, onde
VOCé criaré as imagens principais de sua animagcao.

Desenhe um Personagem Usando a Ferramenta Pencil

1. Clique na ferramenta Pencil na barra de ferramentas.

2. Observe que as opgbes de modificadores na parte inferior da barra de ferramentas mudaram. Clique
no primeiro botdo modificador de quadrado e mantenha-o pressionado para visualizar as opgdes do
Pencil Mode. Vocé pode modificar o lapis para que ele desenhe formas ovais, retangulares e linhas
ou pode desenhar a méo livre com o lapis, e o Flash ird suavizar ou alinhar os segmentos de linha,
dependendo do modo selecionado.

3. Selecione Oval a partir do menu pop-up Pencil Mode.

4. Mova o cursor para a area Stage. Use a ferramenta Pencil para desenhar as trés ovais sobrepostas
para formar o corpo da formiga. A ndo ser que vocé seja um promissor Rembrandt, seu desenho
devera ficar parecido com o da Figura 1-4.

Figura 1-4
Usando a ferramenta Pencil no modo Oval, desenhe o
eshogo do corpo da formiga.

5. Para dar ao corpo uma impresséo de profundidade, exclua uma parte de cada curva no local em que
ela cruza com a outra (Figura 1-5). Para tanto, selecione a ferramenta Arrow na barra de ferramen-
tas. Basta clicar na parte da curva que vocé deseja excluir e pressionar a tecla Backspace ou
Delete. Vocé observara que o Flash segmenta automaticamente as linhas e curvas no local em que
elas se cruzam.
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Figura 1-5
Apbs excluir algumas linhas com a ferramenta Arrow,
aformiga devera ficar parecida com esta.

Os insetos, vocé se lembrara das aulas de biologia do colégio, possuem seis pernas. Entéo, vamos
colocar algumas pernas nesta formiga.

Selecione a ferramenta lapis novamente. Clique no botédo Pencil Mode escolha Smooth. Isso
permitird que vocé desenhe linhas de formato livre.

Desenhe seis pernas na formiga.

Dé a formiga detalhes adicionais desenhando uma antena e boca com a ferramenta Pencil no modo
Smooth.

Finalmente, retorne ao modo Oval e use o lapis para desenhar um olho e a cabeca da formiga.

. O desenho deve, agora, estar parecido com o da Figura 1-6.

Figura 1-6
Voilal Uma formiga n&o t&o perfeita.

Salve Seu Trabalho

a bk ownN =

Escolha File > Save.

Nomeie o arquivo como ant.fla. (.fla é a extenséo padrao de arquivo para filmes do Flash).

O menu pop-up Salvar como tipo deve informar “Flash Movie".

Usando o navegador de disco, selecione uma pasta na qual vocé deseja salvar seu novo arquivo.
Clique no botao Salvar.

Acrescente Cor Usando o Paint Bucket

Agora vocé dara um pouco de cor a formiga.

1.
2.

Selecione a ferramenta Paint Bucket a partir da barra de ferramentas.

Observe que a area de modificadores seré alterada quando vocé selecionar a ferramenta Paint
Bucket. O primeiro modificador € o menu pop-up Fill Color, que contém cores padréo que devem
ficar com uma boa aparéncia em qualquer sistema de computador. (Em termos técnicos, isso significa
a paleta de cor “apropriada ao navegador”.) Usando esse menu pop-up, selecione um cinza-claro.

Com a ferramenta Paint Bucket, clique em cada segéo do corpo da formiga para preenché-lo com a
cor. Deixe o olho na cor branca.

macromedia® 4 CURRICULO DO FLASH



4. Agora, retorne ao menu pop-up Fill Color e selecione o preto.

5. Preencha os olhos da formiga com preto clicando dentro do circulo do olho com a ferramenta Paint
Bucket.

Sua formiga deve estar agora pelo menos parecida com a da Figura 1-7.

Figura 1-7
Use a ferramenta Paint Bucket para colorir a formiga.

ADICIONANDO MAIS ELEMENTOS AO DESENHO

Adicione um Plano de Fundo Usando as ferramentas Brush e Pencil

Em seguida, vocé podera adicionar um plano de fundo ao seu desenho. Vocé deixara o cenario como um
dia ensolarado e colocard um pouco de grama para que a formiga se movimente sobre ela. Consulte a
Figura 1-8 para ver como seré a aparéncia do desenho.

1. A partir da barra de ferramentas, selecione a ferramenta Brush, que se parece com um pincel.

2. Na area de modificadores, use o menu pop-up Fill Color para selecionar um amarelo-brilhante, vivo.

3. O modificador embaixo do menu pop-up Fill Color é o menu pop-up Brush Size. Apanhe um pincel
de tamanho médio a grande para desenhar a parte principal do sol.

4. Na parte superior esquerda do Stage, desenhe um meio circulo para o sol.
5. Agora, escolha um pincel de tamanho menor a partir do menu pop-up Brush Size.
6. Desenhe alguns raios de sol.

Em seguida, adicione um pouco de grama a seu desenho.

Selecione a ferramenta Pencil a partir da barra de ferramentas.

A partir do menu pop-up Pencil Mode, escolha Line.

Escolha um verde-brilhante no menu pop-up de cor.

No menu pop-up Line Thickness, selecione 8.0 para uma linha grossa.

No menu pop-up Line Style, selecione a quinta opgéo, que dara um ar felpudo, pontilhado a linha.

No Stage, desenhe uma linha embaixo da formiga. Desenhe uma linha a um centimetro mais ou
menos a partir da parte inferior do Stage. (Na ligdo 3, vocé colocara botdes de controle nesta area
vazia, por isso é melhor deixar espago agora.)

2 o
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Adicione Texto
Para terminar o desenho, adicione algum texto a imagem.

Selecione a ferramenta Text, representada pela letra A na barra de ferramentas.
Na area de modificadores, deixe o tamanho da fonte em 24 pontos.

No menu pop-up Text Color, selecione uma cor azul-média.

No Stage, clique na ferramenta Text do lado direito do sol.

Digite: “Where's the Picnic?”

a ko=

Where's the picnic?

L L L P u‘-_.‘._‘.. Tt O P e P e e SRRy

Figura 1-8
Use as ferramentas Brush, Pencil e Text para terminar seu desenho.

FAZENDO SELECOES COM A SETA E O LACO

Vocé ja usou a ferramenta Arrow rapidamente para selecionar segmentos de linhas. Nesta segéo,

aprenderé a usar as ferramentas Arrow e Lasso para selecionar e mover partes do desenho.

Selecionando Elementos Individuais com a Ferramenta Arrow

As ferramentas de selecéo no Flash funcionam de maneira um pouco diferente do que nos programas
padrdo de desenho vetorial. Gaste algum tempo para familiarizar-se com o funcionamento da ferramenta
Arrow.

1. Selecione a ferramenta Arrow na barra de ferramentas.

2. Com a ferramenta Arrow, clique na perna traseira da formiga. Observe como o segmento fica
destacado, indicando que esté selecionado (Figura 1-9).

3. Agora, clique na perna dianteira da formiga. Observe que a perna traseira permanece selecionada
também.

4. Para desmarcar, clique em uma area em branco do Stage. Agora, clique na perna dianteira de novo
e observe que esta é a Unica selegéo atual.
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Figura 1-9
A pernatraseira esté destacada, indicando que foi selecionada.

Selecionando Vérios Elementos com a Ferramenta Arrow

1.

2.

Dé um clique duplo na perna dianteira. Observe que o desenho inteiro da formiga fica destacado —
com algumas poucas excegoes.

Agora, posicione o cursor sobre qualquer segmento destacado do corpo da formiga. Clique e
arraste para mover as segdes destacadas. Observe que algumas partes da formiga foram deixadas
para trés, como a cor de preenchimento, o olho e quaisquer outras linhas que ndo estavam
realmente tocando o segmento no qual vocé clicou duas vezes. Seu desenho devera estar parecido
com o da Figura 1-10.
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Figura 1-10
Opa! A formiga foi movida sem que todas as suas partes fossem selecionadas.

Escolha Edit > Undo para mover as linhas da formiga de volta a sua posigéo original.

Clique na cor de preenchimento no corpo da formiga. Observe que ele fica destacado, bem como o
contorno.

Mantenha pressionada a tecla Shift e clique na perna traseira para desmarca-la.

Para desmarcar tudo, clique com a ferramenta Arrow em uma segéo em branco do Stage.

Para selecionar rapidamente o desenho completo da formiga, vocé pode usar a ferramenta Arrow
para desenhar uma caixa de selegdo ao redor da formiga. Posicione a seta a direita da formiga e um

pouco acima dela. Clique e arraste para a esquerda, até que a caixa de sele¢éo contorne totalmente
a formiga. Verifique se a formiga inteira esta selecionada.

Clique em qualquer area da formiga a arraste-a um pouco para a direita. Se vocé tiver selecionado a
formiga de forma apropriada, a formiga inteira devera ser movida para a nova posigéo. Se pedagos
da formiga ficarem para tras, escolha Edit > Undo e tente novamente.
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Selecionando Elementos com a Ferramenta Lasso

Muitas vezes vocé vai querer selecionar um grupo irregular de objetos que nédo se encaixam dentro da
selegéo retangular da ferramenta Arrow. Nesses casos, a ferramenta Lasso podera ajudar.
1. Escolha a ferramenta Lasso na barra de ferramentas; ela esta a direita do Magnifier.

2. Se aformiga ainda estiver selecionada, clique na se¢éo em branco do Stage para desmarca-la.
Como alternativa, vocé pode escolher Edit > Deselect All.

3. Posicione o lago perto do desenho da formiga, mas fora dele. Clique e arraste para desenhar uma
selegéo irregular ao redor de toda a formiga. O desenho completo da formiga deve estar agora
selecionado.

Formando um Grupo

E muito mais facil apenas clicar uma vez na formiga para selecionéa-la, sem precisar seguir todos os
passos que acabamos de utilizar. Agrupando as diferentes partes da formiga, ela sera transformada em
um objeto que podera ser facilmente selecionado e movido.

1. A formiga deve ainda estar selecionada. Se néo estiver, utilize um dos métodos acima para
selecionar todas as partes dela.

2. Escolha Modify > Group. A formiga deve, agora, ter uma borda de selegédo retangular ao seu redor,
indicando que o item esté agrupado (Figura 1-11). Por enquanto, deixe a formiga como um objeto
agrupado. (Quando vocé precisar desmembrar um grupo, escolha Modify > Ungroup ou Modify >
Break Apart. Para compreender a diferenga entre esses dois pontos, consulte os Tépicos da Ajuda
que a Macromedia fornece juntamente com seu programa Flash.)

LR .“‘..';:... .-.l\.d_i__.‘;.. e g P Fan :-‘.,". Y i 1

Figura 1-11

O destaque da selegéo retangular indica que as diferentes
partes da formiga foram agrupadas em um Gnico objeto.

Por enquanto, o desenho da formiga esta completo. Na proxima ligdo, vocé ira animar os desenhos que

criou. Na ligdo 5, aprendera mais técnicas avangadas de desenho no Flash.

MAIS EXERCICIOS PARA APRIMORAR SUAS HABILIDADES

e Faga um novo documento do Flash e experimente as ferramentas de desenho.

¢ Selecione cada ferramenta na barra de ferramentas, uma por uma. Clique em cada modificador
e verifique o que ele faz.

e Gaste um pouco de tempo experimentando as ferramentas Arrow e o Lasso para selecionar,
desmarcar e mover partes do desenho.
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