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INTRODU�ÌO

O Dreamweaver é um programa profissional destinado à criação de sites da Web com recursos

inovadores e recursos abrangentes de planejamento, úteis tanto para os iniciantes como para

desenvolvedores da Web experientes.

Você pode usá-lo para criar visualmente sites da Web, graças a sua interface gráfica de fácil utilização

que mostra as modificações à medida que são efetuadas. Além disso, terá a certeza de que o HTML

gerado nos bastidores sairá consistentemente limpo, conciso e editável.

Ao contrário da maioria dos programas visuais de criação na Web, o Dreamweaver não altera o código

HTML quando importa documentos de um outro programa HTML.

O Dreamweaver oferece muitos recursos que facilitam o design de uma página. Você poderá testar

suas páginas virtualmente usando diferentes navegadores da Web, inserir uma variedade de tipos de

arquivos de multimídia clicando em um botão, selecionar cores de uma paleta apropriada à Web

apresentando convenções de nomeação hexadecimal e até mesmo arquivos FTP para um servidor de

arquivos remoto a partir do programa. Entre os recursos mais avançados, está incluído o suporte para

as últimas inovações da Web, incluindo Páginas de Estilo Cascata e HTML Dinâmico.

Neste curso, você irá aprender fazendo, usando o Dreamweaver para desenvolver passo-a-passo

exemplos de projetos da Web. Aprenderá a criar páginas HTML, formatar texto, inserir imagens e

objetos multimídia, definir links e trabalhar com tabelas e quadros, páginas de estilo e recursos HTML

Dinâmico.

O Dreamweaver acompanha um sistema extensivo de Ajuda on-line, incluindo tutoriais e arquivos de

Ajuda que podem ser pesquisados. A maioria das paletas também tem Dicas de Tela que descrevem a

função de ícones quando o cursor é mantido sobre eles.

O CD-ROM que acompanha as lições contém exemplos de arquivos que facilitam o acompanhamento

dos exercícios passo-a-passo, à medida que se passa de uma lição para outra.
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LI�ÌO 1: FAMILIARIZANDO-SE

OBJETIVOS

Ao final desta lição, você será capaz de:

• definir uma pasta Raiz Local para seu site da Web
• entender a interface, as paletas e os inspetores do Dreamweaver
• criar um novo documento e executar formatações básicas de texto
• alterar formatos de cabeçalhos e parágrafos e alinhar o texto na página
• visualizar páginas em um navegador

SUMçRIO

A melhor maneira de conhecer o Dreamweaver é utilizando-o. Nesta lição, você irá aprender a configurar

um site, usar as janelas e paletas do Dreamweaver para a criação de uma página, adicionar texto e

inserir uma imagem. Você também irá aprender a acessar o inspetor HTML e a visualizar sua página em

um navegador.

Antes de abrir o programa, abra o CD-ROM que acompanha estas lições e copie a pasta denominada

“Examples” na pasta Dreamweaver para seu disco rígido. Coloque-a na érea de trabalho ou em um local

em que ela possa ser facilmente encontrada.

EXERCêCIOS

CONFIGURANDO UM SITE

O Dreamweaver facilita a construção de um site da Web em seu computador local e sua transferência

posterior para um servidor Web. Antes de começar a criação de páginas, convém estabelecer um local

para seu site para que o programa possa manter o controle de seus arquivos quando mais páginas,

gráficos e outros elementos forem adicionados.

Defina uma Pasta Raiz Local

Primeiro, abra o programa e defina uma pasta Raiz Local correspondente ao diretório raiz no servidor
Web. Seu site local funcionará como um “espelho” do site que está realmente on-line.

1. Com o programa aberto, selecione File > Open Site > Edit Sites e clique no botão New Site.
2. Quando a caixa de diálogo Site Information for aberta (Figura 1-1), digite “bookstore” como o nome

do site.
3. Clique no botão Browse (PC) ou Choose (Mac) para definir uma pasta de seu disco rígido como a

pasta Raiz Local deste site. Nesta pasta serão armazenados os arquivos do site. Abra a pasta
“Examples” que foi copiada do CD-ROM e selecione a pasta “bookstore”.

4. As demais opções da caixa de diálogo servem para estabelecer a conexão entre seu site local e um
servidor remoto. Se um servidor remoto ainda não foi estabelecido, você pode deixar estas opções
em branco e retornar mais tarde para preenchê-las.

5. Clique em OK. Você verá um diretório do site. Voltaremos a esta tela quando explicarmos como se
carrega arquivos em um servidor remoto. Por enquanto, feche a janela e volte ao espaço de trabalho
do Dreamweaver para construir a primeira página.
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USANDO OS COMPONENTES CHAVE 
DO ESPAÇO DE TRABALHO DO DREAMWEAVER

Agora você está vendo a janela Document (Figura 1-2) que exibe o documento atual do modo como
será mostrado em um navegador da Web. Uma página em branco é aberta automaticamente quando o
programa é aberto. Você sempre poderá abrir uma outra página em branco selecionando File > New.

Definindo as Propriedades da Página de sua Primeira Página

1. Com a página aberta, clique com o botão direito do mouse (PC) ou clique pressionando Control
(Mac) e selecione Page Properties (Figura 1-3) ou escolha Modify > Page Properties na barra de
menus.

2. Digite um título na caixa de texto. Este título irá aparecer na lista Marcadores ou Favoritos do
navegador e, por isso, deve ser descritivo. Chame esta página de “Mythical Bookstore”.

3. Clique na caixa próxima a Background Color. Quando a paleta de cores aparecer, você poderá
selecionar uma amostra de cor. A melhor cor para este exercício é branco, a cor padrão. Se quiser
adicionar uma imagem de plano de fundo, use o botão Browse junto a Background Image.

4. Selecione a caixa junto a Text Color e escolha uma cor escura para o texto. Observe que é possível
escolher cores diferentes para Link Color (texto vinculado), Visited Links (selecionados
anteriormente) e Active Links (a cor do link no momento em que é selecionado). Você irá aprender
mais sobre os links na próxima lição.

5. Clique em OK e salve sua página selecionando File > Save As. Salve a página como index.htm.
Essa será a “página de entrada” do site que está sendo construído.
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Figura 1-2
A Janela
Document

Figura 1-1
A caixa de
diálogo Site
Information
está onde foi
configurada a
pasta Raiz
Local.



O inspetor Property

1. Depois de fechar a janela Page Properties, clique na página e digite as palavras “Mythical
Bookstore”. Se o inspetor Property (Figura 1-4) ainda não estiver aberto, selecione Window >
Properties. O inspetor Property exibirá as propriedades do objeto selecionado.

2. Realce as palavras digitadas para modificar o formato e a fonte usando os menus do inspetor
Property. Altere o formato para Heading1 e observe como o tamanho e o estilo são alterados.
Modifique a fonte padrão para “Arial”. Mude o tamanho da fonte para “7” e depois retorne ao
tamanho padrão. Clique no ícone Align Center (no grupo, no lado direito da linha superior) para
centralizar o texto na página.

3. Coloque o cursor após o cabeçalho e pressione Enter (PC) ou Return (Mac) e digite seu endereço.
Realce a nova linha e altere o tamanho da fonte para “5”. Altere a cor da fonte clicando na caixa
cinza embaixo da janela de tamanho de texto. Observe que as alterações de cor efetuadas no
inspetor Property são válidas apenas para o item selecionado e não para toda a página. Deixe a
janela aberta. Mais tarde, examinaremos outras opções.

Figura 1-4
O inspetor Property de texto facilita bastante o controle de atributos, como fontes e cores de escolha 
de formato. Quando o elemento de uma página é selecionado — como texto ou imagem — o inspetor 
Property exibe apenas as opções de atributo disponíveis para este elemento. Para acessar recursos 
mais avançados, clique na seta pequena, no canto direito inferior do inspetor Property.
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A paleta de cores do Dreamweaver é “apropriada à Web” e usa nomes de cores
Hexadecimal de seis dígitos. As cores selecionadas se manterão fiéis, mesmo se o
computador do usuário final exibir somente 256 cores. Se não estiver satisfeito com
as opções disponíveis, você poderá criar cores personalizadas, clicando no ícone
Paleta de Pintura, na parte inferior direita da paleta de cores, e criar suas próprias
cores na caixa de diálogo Seletor de Cores. Quando exibidas em um monitor de 256
cores, elas serão padronizadas na cor apropriada à Web mais próxima. Também é
possível inserir o número “hexadecimal” da cor desejada ou seu nome (por ex.,
Navy, Maroon, White) diretamente na janela.

Figura 1-3
A caixa de
diálogo Page
Properties
permite que
as cores de
plano de
fundo e do
texto de toda
a página
sejam
alteradas.
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A paleta Objects

1. Selecione Window > Objects para
abrir a paleta Objects. Esta
ferramenta contém botões para a
inserção de vários tipos de objetos,
como imagens, tabelas, camadas,
applets e outros elementos de
multimídia. (Figuras 1-5 a 1-6). Manter
o cursor sobre cada um dos ícones da
paleta abre uma caixa que explica a
função de cada botão.

2. Agora, vamos inserir uma figura entre
o cabeçalho e o endereço. Coloque o
cursor logo após o cabeçalho e
pressione Enter (PC) ou Return (Mac)
para abrir um espaço.

3. Clique no botão superior da Paleta
Objects para escolher uma imagem,
na caixa de diálogo Insert Image clique
no botão Browser e passe para a
pasta “images” localizada na pasta
Raiz Local (“bookstore”). Clique no
arquivo jpeg denominado books.jpg,
selecione-o e clique no botão Select
e, em seguida, clique em OK. A figura
deve aparecer embaixo do cabeçalho.

4. Coloque o cursor junto à imagem sem
selecioná-la e clique no ícone Align
Right no inspetor Property. A imagem
irá para o lado direito da página.
Agora, clique no ícone Align Left e
depois clique no ícone Align Center
para retorná-la ao centro da página.

5. Clique na figura e observe que o
inspetor Property automaticamente
muda para exibir as propriedades da
imagem, inclusive suas dimensões e
localização. (Observe que a opção
Align serve para alinhar uma figura
junto a um bloco de texto e não para
alinhá-la na página. Vamos deixá-la de
lado por enquanto e examiná-la na
próxima lição.

6. Se você não gostar da combinação de
cores, modifique as cores na janela
Page Properties ou no inspetor
Property de texto.

7. Lembre-se de salvar as alterações
feitas.
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Figura 1-5
A paleta Objects com seus ícones
comuns exibidos. Outras escolhas são os
ícones Forms e os ícones Invisible.

Figura 1-6
A seta pequena no alto da paleta Objects
rola para abrir outros conjuntos de
ferramentas, inclusive um abrangente
conjunto de ferramentas Forms.

Figura 1-7
Invisibles Panel da paleta Objects serve para inserir
objetos que não são visíveis na janela de documento.



O Launcher

Uma outra ferramenta importante é o Launcher que pode ser acessado a
partir de Window > Launcher. O Launcher tem botões que abrem ou fecham
vários inspetores e paletas, inclusive o inspetor HTML. Mais tarde,
examinaremos os outros.

O Inspetor HTML

Abra o inspetor HTML clicando no botão HTML do Launcher e você verá o código-fonte HTML gerado
pelo programa para a página em que está trabalhando. O código-fonte com marcas HTML situa-se atrás
de cada página HTML indicando os elementos de códigos entre sinais de maior e menor, como
mostrado neste exemplo, onde <H1> equivale a Título1 de um processador de texto.

<h1 align=”center”><font face=”Arial” color=”#9933FF”>Mythical Bookstore </font></h1>

Estes elementos são instruções que informam ao navegador como a página deve ser exibida. Observe
que cada conjunto de instruções requer uma marca inicial e uma final. A instrução align=“CENTER” é
um exemplo de atributo, ela modifica o elemento ao qual é adicionada. Na verdade, o usuário apenas vê
as palavras “Mythical Bookstore”.

Se você é um iniciante em HTML, convém dedicar algum tempo estudando o código para as marcas
criadas para que possa entendê-las e editar o código diretamente, quando necessário. Existem no
mercado muitos livros bons que podem ajudá-lo a conhecer HTML.

O Dreamweaver permite que a janela de documento e o inspetor HTML permaneçam abertos ao mesmo
tempo para possibilitar o acompanhamento das alterações feitas nas duas visualizações. Quando se
realça o texto na janela de documento, este também aparece realçado no inspetor HTML, conforme
visto na Figura 1-9.

Observe que o inspetor HTML pode ser acessado de quatro maneiras diferentes: a partir do Launcher,
com a ajuda da tecla de função F10, de um botão situado na base da janela de documento ou a partir da
barra de menu (Window > HTML).

Figura 1-9
O inspetor HTML do Dreamweaver é totalmente integrado com o editor WYSIWYG. 
As alterações efetuadas em uma janela aparecem automaticamente na outra.
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O Launcher
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VISUALIZANDO SEU TRABALHO EM UM NAVEGADOR DA WEB

É aconselhável testar o trabalho em diferentes navegadores para garantir a boa apresentação das

páginas criadas.

Configurando um Navegador de Visualização

O Dreamweaver facilita a configuração de links de visualização com diferentes navegadores. Trata-se de
uma configuração de preferência que pode ser acessada a partir do menu Edit > Preferences ou a partir
de File > Preview in Browser > Edit Browser List.

1. Escolha Edit > Preferences e examine os vários tópicos de preferências mostrados na Figura 1-10.
Convém mudar algumas destas definições mais tarde. Escolha Preview in Browser e clique em Add.

2. Digite o nome de um navegador (como Netscape ou Internet Explorer) na caixa de texto Name e
clique no botão Browse para abrir a caixa de diálogo Select Browser e localizar o navegador que
deve ser configurado.

3. Clique no arquivo do programa no navegador ou selecione e clique em Abrir (Open) e depois em
OK. Clique em OK para fechar a caixa de diálogo Preferences.

Agora o navegador foi adicionado à lista nas opções Preview in Browser. Você pode adicionar
outros navegadores da mesma maneira e designar um deles como seu navegador principal. 

4. Visualize a página usando a tecla de função F12 do Dreamweaver para abrir instantaneamente a
página no navegador principal. Compare-a à página que aparece na janela Document e no inspetor
HTML.

Mais tarde, aprenderemos como o Dreamweaver também pode testar seus documentos nos diferentes
navegadores, “virtualmente” sem uma visualização, e fornecer um relatório dos eventuais problemas ou
deficiências. Você pode acessar este recurso útil a partir de File > Check Target Browsers.

MAIS EXERCÍCIOS PARA APRIMORAR SUAS HABILIDADES

• Examine as várias opções de menu e procure se sentir à vontade no programa. Explore as
diferentes paletas e inspetores, bem como seus diversos acessos e utilizações.

• Acompanhe o exercício desta lição para criar uma outra página, usando diferentes textos e
imagens (ou faça uma cópia da página que acabou de criar) e teste outras definições de cor e
alinhamento contidas nas Janelas dos inspetores Page Properties e Property.

• Com a nova página aberta, abra e feche o inspetor HTML com a tecla F10 e verifique como as
alterações feitas na janela de documento se refletem no código HTML. Faça alterações no
código HTML e veja o que acontece com a janela de documento.

• Explore os tutoriais e a seção Ajuda do programa.
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Figura 1-10
Opções da janela
Preference do
Dreamweaver


